2013-10-10, bewerkt op 2016-12-31

Tweak glasvezel en OpenWRT

Waar Tweak voor het glasvezelpakket "Groen" eerder gelijk was aan KPN glasvezel, leveren ze de laatste tijd eigen apparatuur uit. Dit betekent bijvoorbeeld dat je geen Experiabox krijgt maar een ZyXEL VMG8324-B10A-router, die overigens non-branded is en waarop je gewoon een admin-account hebt. Je hebt dus in principe alle vrijheid en dit zal voor veel mensen een reden zijn om deze router gewoon te gebruiken. Wil je echter een eigen router gebruiken, bijvoorbeeld één met OpenWRT, dan is deze tutorial voor jou. Ik leg uit hoe je de ZyXEL vervangt door een router, en in dit voorbeeld zal ik OpenWRT op een TP-Link TL-WR1043ND gebruiken. Ik ga in deze tutorial vanuit dat je bekend bent met de basics van networking en OpenWRT.

Heb je KPN glasvezel of WBA/WMP via Tweak, dan verwijs ik je graag door naar netwerkje.com.

Geleverde apparatuur

Als het goed is heb je een NTU en een router (ZyXEL VMG8324-B10A) ontvangen. De NTU is het eigenlijke glasvezelmodem; deze zet de optische signalen om naar Ethernet. Deze blijven we gewoon gebruiken. De router is het apparaat dat we (deels) gaan vervangen.

Netwerktechnische opzet

Waar bij WBA/WMP de verschillende diensten (namelijk internet, telefonie en TV) elk over een verschillend VLAN getagd binnenkomen, is dit hier niet het geval. De internetverbinding komt vanuit de NTU op VLAN 34 getagd binnen. De telefonie gaat gewoon via SIP over dezelfde internetverbinding. Deze SIP-gegevens zijn trouwens gewoon uit te lezen op de ZyXEL en het is daarmee dus mogelijk om iets anders (zoals een PBX-systeem of een SIP-telefoon) te gebruiken. Dat is fijn, Tweak doet tenminste niet zo geheimzinnig over deze gegevens, iets dat we van KPN zeker niet kunnen zeggen.

Bij WDA/WMP wordt het internet geleverd over VLAN 6 in de vorm van een PPPoE-tunnel die ook voor wat overhead zorgt. Gelukkig hebben we ook hier geen last van, de verbinding wordt gewoon in de vorm van IPoE geleverd en het publieke IP-adres is op te halen via DHCP.

Hardware

We hebben dus een OpenWRT-capable router nodig die een managed switch heeft ingebouwd. Het enige wat je qua hardware hoeft te doen, is een verbinding te leggen van de NTU naar de WAN-poort van de router.

Configuratie OpenWRT

Switch

Allereerst moeten we OpenWRT uitleggen dat de internetverbinding getagd binnenkomt op VLAN 34. Dit doen we in /etc/config/network, onderaan in het "switchgedeelte". Normaalgesproken staat er op de TL-WR1043ND zoiets dergelijks:

config switch
        option reset '1'
        option enable_vlan '1'
        option enable_vlan4k '1'
        option name 'switch0'
config switch_vlan
        option vlan '1'
        option device 'switch0'
        option ports '1 2 3 4 5t'
config switch_vlan
        option vlan '2'
        option device 'switch0'
        option ports '0 5t'

Hierbij is misschien wat uitleg noodzakelijk. Als het nog niet duidelijk was, we zitten hier te kijken naar de configuratie van de ingebouwde managed switch. Poort 1 t/m 4 zijn de LAN-poorten. Poort 0 is de WAN-poort en poort 5 is de NIC van de router zelf. Elk VLAN komt dus getagd binnen op de router, wat ook wel logisch is. In de standaardconfiguratie gaat OpenWRT er vanuit dat er niets getagd binnenkomt op de WAN-poort, maar voor onze situatie is dat wél het geval. We moeten de configuratie dus wat aanpassen, en wel naar het volgende:

config switch
        option reset '1'
        option enable_vlan '1'
        option enable_vlan4k '1'
        option name 'switch0'
config switch_vlan
        option vlan '1'
        option device 'switch0'
        option ports '1 2 3 4 5t'
config switch_vlan
        option vlan '34'
        option device 'switch0'
        option ports '0t 5t'

Interfaces

Kijk nu meteen even iets naar boven, in de zelfde file:

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

Dit veranderen we ook naar eth0.34. (Dit correnspondeert met VLAN nummer 34 die we in het switch-gedeelte hebben opgegeven)

config interface 'wan'
        option ifname 'eth0.34'
        option proto 'dhcp'

Dat was alweer de configuratie voor OpenWRT. Na een reboot van je router zou je internet moeten werken.

Telefonie

Het makkelijkst is om voor de telefonie gewoon de ZyXEL te blijven gebruiken. Wel moeten we deze iets aanpassen zodat hij in ons nieuwe netwerk past.

  1. Ga naar de webinterface van de ZyXEL. De inloggegevens zijn admin:1234 .
  2. Ga naar Network Setting -> Broadband
    1. Verwijder hier alle WAN-interfaces.
    2. Maak een nieuwe WAN-interface aan met de mode "bridge". Zet VLAN op "inactive".
  3. Ga naar Network Setting -> Wireless
    1. Disable dit.
  4. Ga naar Network Setting -> Home Networking
    1. Geef de ZyXEL een IP-adres in de range van de rest van je netwerk.
    2. Disable de DHCP-server.
  5. Ga naar Security -> Firewall
    1. Disable dit.

We laten de VOIP-settings zoals ze zijn. Sluit nu de ZyXEL-router met de WAN-poort aan op de rest van het netwerk. Je kunt de LAN-poorten van de ZyXEL nu als switch gebruiken omdat hij de WAN-poort met de LAN-poorten gebridged heeft. De ZyXEL is nu vanuit de rest van je netwerk te bereiken op het IP-adres dat je hem in stap 4.1 gegeven hebt. Je kunt nu de telefoons op de ZyXEL aansluiten.